2021/07/08

MANUAL

FAQ:_Migratedで始まるテーブルの削除

## 概要 プリザンターは「[バージョンアップ](/manual/release-notes-core)」を行う際にテーブル構成のマイグレーションを行うことがあります。テーブル名が_Migratedで始まるテーブルは、マイグレーション前のテーブル構成およびデータのバックアップです。バージョンアップが成功した後はこれらを削除してもプリザンターの動作には影響ありません。本手順では、バージョンアップで発生した_Migratedで始まる名前のテーブルの削除を行います。 ## 注意事項 1. 本手順はデータベースを直接操作するため、危険が伴います。事前に「[バックアップ](/manual/faq-backup-and-restore)」を取得することを強くお勧めします。 ## 対象 1. 本手順はSQL Server及びMicrosoft AzureのSQL Databaseを利用した環境を対象としています。 ## 前提条件 1. SQL Server Management Studioをインストールする必要があります。 1. SQL Server Management Studioをインストールした環境とデータベースの環境が接続可能である必要があります。 ## 操作手順 1. SQL Server Management Studioを起動してプリザンターのデータベースサーバに接続してください。 1. 「オブジェクト エクスプローラー」のツリーから「データベース」「Implem.Pleasanter」「[テーブル](/manual/table)」を展開してください。 1. _Migratedで始まるテーブルを右クリックし、「削除(D)」をクリックしてください。 1. _Migratedで始まるテーブルが削除されたことを確認してください。 ## 関連情報 <div id="ManualList"><ul><li><a href="/manual/release-notes-core">プリザンターの直近3ヶ月のバージョンアップ情報</a><span>2021/10/24 up</span></li> <li><a href="/manual/release-notes-core-history">プリザンターの過去のバージョンアップ情報</a><span>2021/10/17 up</span></li></ul></article> <ul><li><a href="/manual/release-notes-framework">.NET Framework版 プリザンターの直近3ヶ月のバージョンアップ情報</a><span>2021/10/24 up</span></li> <li><a href="/manual/release-notes-framework-history">.NET Framework版プリザンターの過去のバージョンアップ情報</a><span>2021/10/17 up</span></li></ul></article> <ul><li><a href="/manual/version-up-azure">プリザンター .NET Framework版 Azure環境のバージョンアップ手順</a><span>2021/07/21 up</span></li> <li><a href="/manual/version-up-net-framework">プリザンター .NET Framework版のバージョンアップ手順</a><span>2021/07/21 up</span></li> <li><a href="/manual/version-up-net-core">プリザンターのバージョンアップ手順(Linux)</a><span>2021/08/24 up</span></li></ul></article> <ul><li><a href="/manual/table">テーブル機能</a><span>2021/05/30 up</span></li></ul></article> <ul><li><a href="/manual/faq-backup-and-restore">FAQ:プリザンターのDBデータをバックアップする方法とリストアする方法を知りたい</a><span>2021/05/05 up</span></li> <li><a href="/manual/faq-backup-schedule">FAQ:プリザンターのDBデータを定期的にバックアップしたい</a><span>2021/05/05 up</span></li> <li><a href="/manual/faq-downgrade">FAQ:プリザンターのバージョンをダウングレードしたい</a><span>2021/05/23 up</span></li></ul></article> <ul><li><a href="/manual/faq-version-up-0-50-177">FAQ:.NET Framework版の以前のバージョンから ver.0.50.177 以降にバージョンアップする場合の注意</a><span>2021/05/23 up</span></li> <li><a href="/manual/faq-version-up-errors">FAQ:バージョンアップ実行時のエラーについて</a><span>2021/05/23 up</span></li> <li><a href="/manual/faq-code-definer-stoped">FAQ:プリザンターのバージョンアップ時に、「Implem.CodeDefinerは動作を停止しました」というエラーが表示される</a><span>2021/05/23 up</span></li></ul></article></div><input id="SearchTextHidden" type="hidden" value="" />
このページをシェアする